HELP - Just got the remote and need IR help!


After a long wait I got my remote and I’m impressed with the build quality. However, I’m a retired software engineer but boy is this thing frustrating to set up! I was able to get it to control my LG TV but the next device I wanted to set up was my Frontier Cable DVR - and then progress totally stopped! I couldn’t find it in the database (also tried Verizon DVR and still no good) so I set up a blank device to learn the IR codes. It took me a good while to just figure out how to do it (this forum is a life saver!!) but then I realized every time I went to learn an IR code the hub blinked red twice. I found out that meant that the learn failed. I tried other buttons and they also failed. The source was either the Harmony Elite or the original Frontier remote - both had the same fail results.

I then tried to learn a code from my Dennon AVR and the hub blinked green meaning it took. So my problem is not being able to learn any IR signals from the Frontier DVR. I don’t understand that as I’m sure the Frontier DVR’s commands are the same type of IR signal as any other device. Plus the Harmony Elite (and several other remotes I’ve used in the past) had no problem with the Frontier DVR commands.

So bottom line, has anyone with a Frontier (or Verizon) DVR got it to work with the remote? Other than the Frontier branding the DVR also says ARRIS VMS1100.

Any help will be greatly appreciated!


This is immensely curious. I am able to recreate your issue using my Harmony to transmit. I tried unplugging the extra emitters, as well as setting that particular device to be output via my Harmony remote only. I adjusted inter-command delays, repeats, etc. No dice.

I also checked the log files. Unfortunately, no dice there, either. It seems like the dock is not reporting back log messages for well, anything. I was able to successfully learn a command for a different product (LG TV Power On, for example) and that went just fine.

I think the only next steps are to figure out how to get some kind of logging out of the dock, unfortunately. I am not quite sure how feasible that’s going to be with my current knowledge level. Hoping someone from UC can chime in!

A quick update - I used instructions provided by the developers on GitHub and set up a SysLog server using Kiwi SysLog Server Free Edition. I then used the WebSocket King Client to point to my SysLog server and started getting log messages directly from the dock.

Unfortunately, this is where my luck started to run out.

Here is my response when testing with a code that “works” (ex. Power Toggle from my Marantz AVR)

Expand for Log Messages - Success
Priority Source (Parsed) Message
Daemon.Debug UC-Dock-xxx irLogLearn ir_learn task stopping
Daemon.Debug UC-Dock-xxx API IR Receive off
Daemon.Info UC-Dock-xxx IRLEARN Sending message to API clients: {type:event,msg:ir_receive,ir_code:1;0xC0C;12;0}
Daemon.Debug UC-Dock-xxx IRLEARN Learned: 1;0xC0C;12;0
Daemon.Debug UC-Dock-xxx IRLEARN ir_learn task starting
Daemon.Debug UC-Dock-xxx API IR Receive on

But now let’s try this same thing with your Arris codes

Expand for Log Messages - Fail
Priority Source (Parsed) Message
Daemon.Debug UC-Dock-xxx irLogLearn ir_learn task stopping
Daemon.Debug UC-Dock-xxx API IR Receive off
Daemon.Info UC-Dock-xxx IRLEARN Learning failed: unknown code
Daemon.Debug UC-Dock-xxx API IR Receive on
Daemon.Debug UC-Dock-xxx IRLEARN ir_learn task starting

Interestingly, I ran into an issue with my Marantz receiver where certain commands could be taught (ex. Power Toggle) while others could not (discrete Power On or discrete Power Off).

Looking at the Marantz documentation, those codes look pretty similar, but the discrete Power Off command is longer as it has an extension - check out the table below:

Comparison of IR Codes
Command Name RC5 System RC5 Command RC5 Extension Hex Code (Basic Commands Only) Remote Two Learned Value
POWER ON/OFF 16 12 0000 0073 0000 0018 0020 0020 0020 0020 0020 0020 0040 0020 0020 0020 0020 0020 0020 0020 0020 0020 0020 0040 0020 0020 0040 0020 0020 0C5B 0020 0020 0020 0020 0020 0020 0040 0020 0020 0020 0020 0020 0020 0020 0020 0020 0020 0040 0020 0020 0040 0020 0020 0498 1;0x40C;12;0
POWER ON 16 12 01 0000 0071 0000 0024 0020 0020 0020 0020 0020 0020 0040 0020 0020 0020 0020 0020 0020 00A1 0020 0020 0020 0040 0020 0020 0040 0020 0020 0020 0020 0020 0020 0020 0020 0020 0020 0020 0020 0040 0020 0AAB 0020 0020 0020 0020 0020 0020 0040 0020 0020 0020 0020 0020 0020 00A1 0020 0020 0020 0040 0020 0020 0040 0020 0020 0020 0020 0020 0020 0020 0020 0020 0020 0020 0020 0040 0020 04B0 N/A

I’m going to keep digging into this, I might be onto something here. In another thread, you mentioned you found some IR codes for the remote. Would you mind linking those to me? I would like to try and recreate on my end.

The Frontier DVR appears to be the Arris Gateway Portal that they acquired Moxi for. The challenge you’re having is that the original remote used what are called toggle bits. There’s an explanation and discussion of it here: RC: Toggle-bit IR Codes for Shaw Gateway, but basically each function has two hex codes and alternates between them with each press to avoid unintended duplicate presses.

I would register for Global Cache and see if their codes work (you can download 16 codes a day do it will take a couple of days to replicate that remote). You’re looking for the Arris Moxi Shaw Gateway Portal Receiver codes.

1 Like

Wow, trying to set up this remote is getting more complicated by the minute!!

Quinterly, Thanks so much for the info. I read part of your referenced Remote Central posts about the toggle bit and I kind of understand it. But if its purpose is to send out 2 different codes with alternating presses then if I’m only pressing the button once when trying to learn why should the R2 reject the code. I even dug out my old All In One remote and it learned the code from the DVR’s remote with no problem and then I tried to use the AIO to learn to the R2 and it still rejected it.

I actual have already signed up with the Global Cache as a verified used and I can download full code sets. I’ve been working with the Arris VMS Series Hybrid code set and most of the codes seem to work however I thought the ENTER code worked but the last time I tried it changed the aspect ratio on the DVR and not the ENTER function. I’ll give the Moxi Shaw code set a try.


Toggle bit codes are not yet supported by Remote Two: Support IR Remote Controls that use Toggle Bit · Issue #126 · unfoldedcircle/feature-and-bug-tracker · GitHub

1 Like

To rss:

I was able to register with the Global Cache IR database and download individual codes which seem to work on my Frontier DVR (although some codes don’t work properly!). I’ll paste two of the codes at the end of this post.

Another problem! Now that I was able to update the remote’s firmware I can’t seem to learn ANY codes. In the past I was able to learn codes from my LG TV remote but now when I try I DO GET the double green blink but it does not show up in the web configurator screen to be saved. Scratching my head about this. Any thoughts?


code set: 3632
function: DIGIT 0
code1: sendir,1:1,1,38000,1,37,339,169,19,84,19,84,19,84,19,84,19,84,19,84,19,84,19,84,19,84,19,84,19,84,19,84,19,84,19,84,19,84,19,84,19,1128,339,84,19,3347
hex code1: 0000 006C 0012 0002 0153 00A9 0013 0054 0013 0054 0013 0054 0013 0054 0013 0054 0013 0054 0013 0054 0013 0054 0013 0054 0013 0054 0013 0054 0013 0054 0013 0054 0013 0054 0013 0054 0013 0054 0013 0468 0153 0054 0013 0D13
hex code2:

code set: 3632
function: DIGIT 1
code1: sendir,1:1,1,38000,1,37,339,169,19,169,19,84,19,84,19,84,19,84,19,84,19,84,19,84,19,84,19,84,19,84,19,84,19,169,19,169,19,169,19,169,19,1128,339,84,19,3347
hex code1: 0000 006C 0012 0002 0153 00A9 0013 00A9 0013 0054 0013 0054 0013 0054 0013 0054 0013 0054 0013 0054 0013 0054 0013 0054 0013 0054 0013 0054 0013 0054 0013 00A9 0013 00A9 0013 00A9 0013 00A9 0013 0468 0153 0054 0013 0D13
hex code2:

Never truer words spoken. And spoken by a software professional! Not much hope for us mere mortals, that is, without a user guide for reference.

To be fair, he’s trying to set up a deprecated piece of equipment that uses an usual approach to IR configuration. Not easy.

However, I do have an MX990 and I know the CCP codes for the gateway work (use to have the hardware and had no problem controlling it with URC remotes) so I can load them into that remote and try learning them with the R2. If it works, I’ll upload a file in the next bit.

Hi Quinterly,

Yes, if you are successful with the codes for the Gateway please upload the files as that would be greatly appreciated!


Two different versions to try. The first is a download from RemoteCentral in Pronto format … it’s likely the better one to try: Dropbox - Arris Moxi Gateway (Pronto).csv - Simplify your life

If that doesn’t work, I have a learned set here (but I don’t have the device anymore so I can’t test it). It’s in R2 Hex format: Dropbox - Arris Moxi Gateway.csv - Simplify your life

Hi Quinterly,

I’m not home right now but I will try it as soon as I can. I really appreciate your help!


Hi Quinterly,

Your files uploaded into the remote flawlessly but unfortunately neither of them worked with my Frontier DVR.

I seem to be getting one step forward and then two giant steps backward.

I have the dock hardwired into a switch in my network and all of a sudden it won’t connect. I factory reset everything and started over using Wi Fi for the dock and at least now its connecting. I created 3 different blank devices: 2 for your 2 different codes sets and one for the VMS code set I was starting to have success with. The 2 devices with your codes sets did not work while the VMS codes worked for some commands.

But I now seem to have a bigger problem. When I go into the user interface on the web configurator all I get is the 2 revolving circles. The only way I could add the devices to a user page was on the remote itself. Do you have any idea why that’s happening?


Hi Gerry,

I think the web configurator issue is your browser caching data. When I first got the remote, I used Firefox to setup the remote. Once I updated the firmware I noticed the version number didn’t change on the home screen and if I wanted to access any sections I would just get a spinning circle. I swapped to Chrome which I hadn’t used before for the remote and it accessed the web configurator with the correct version displayed. Since then I have just used Chrome to manage the remote for ease, but I assume I just need to clear the cache on the Firefox and it would work again.

I think @LewLRX probably has answered your configurator issue (i would have suggested cache as well or trying Firefox instead of a chromium based browser).

On the IR codes, it’s possible I’m working from an assumption about the hardware and it’s not the Arris gateway. Can you get the model number from either one of your portals or the gateway itself?


The DVR is definitely Arris as on the front panel to the right is the Frontier branding and on the left its says " VMS 1100 ARRIS". The code set I’ve had some, and only some (!) success, I got from the Global Cache and is called: “Arris VMS Series Hybrid Cable/IPTV Receiver - Set #: 3632”.

So I assume VMS 1100 is the model number.


Thanks so much for the info. My go to browser is MS Chrome Edge and is what I’ve been using but I hate to clear the cache as all my saved data will go away. I also have Firefox so I think I’m going to make sure and clear FF’s cache and use that for the Web Configurator and see how that works out.



Finally made some (only some!) forward progress today. But first some general comments. I’m sure if Unfolded Circle can fix all the bugs and add features (that should have been there in the first place!) the R2 will become a very powerful and useful remote. However in all my experience of using many many different remotes, both universal and programmable, the R2 is the least “ready for use out of the box” remote that I ever worked with. I was describing to a friend all the problems I’ve been having and he said that it sounds like it not even in Beta but is an Alpha product!!! I’m NOT giving up but boy its going to be al long time before I’ll be able to use this as my primary remote!

First thing I did today was to factory reset both the hub and the remote - I wanted to start from scratch. Everything came back up seemingly with no problems. My hub is hardwired into a switch in the network and the connection seems ok.

It seems that the web configurator is sensitive to cache data so I cleared all cache info from Firefox and I was able to connect and get to all design pages. So I going to exclusively use Firefox to connect so that I can clear the cache data in the future without affecting my normal usage of MS Chrome Edge for all my other browsing.

I then put my LG TV back in using the Generic TV setting and initially it did not work but I’m sure i had it working before. Turns out the not-long-enough cable and weak IR blaster was the culprit. Putting the blaster closer to the TV and it worked.

Then back to my Frontier DVR. I had tried the two code sets that Quinterly suggested and neither worked. So I went back to the code set where I got some to work and they still did but the very important command of ENTER (also called OK) did not work and instead changes the picture aspect ratio. I now know that I cannot learn anything from the DRV’s remote because it uses the “Toggle Bit.” But I did read somewhere that Toggle Bit codes will be able to learned in the future.

[SOAP BOX mode on.] If you going to release a new remote which has a limited data base of ready to use code sets, then you should MAKE SURE that IR codes from ALL remotes (including toggle bit codes) should be able to be learned from the original remote! [SOAP BOX mode off.]

So I at least have a few things kind-of working. Hopefully someone can point me to a better source for the ENTER command for my Frontier DVR. In the mean time I hope more firmware updates keep coming so that more of us can really start using the R2 in our setups.


Try this one for OK:

0000 006d 0012 0002 0157 00ac 0012 00ac 0012 0056 0012 0056 0012 0056 0012 00ac 0012 0056 0012 0056 0012 0056 0012 0056 0012 0056 0012 0056 0012 0056 0012 0056 0012 00ac 0012 00ac 0012 00ac 0012 049e 0157 0056 0012 0d2b

It’s from a Motorola QIP FiOS box, but apparently all FiOS boxes use the same IR codeset.



Could you please direct me to the full code set for the Motorola QIP FIOS box just in case I need some other codes.


Awesome … got it from Global Cache … just used Motorola/STB/QIP as the device.