Newbie HA Question

Been using HomeBridge for a while and very happy with it. Pretty much every device in my home appears in the Apple Home app and can be voice controlled by Alexa. In fact, just installed a motorized screen I can lower/raise with Alexa and then control my Capsule 3 Laser projector with R2 and the Android integration - very cool!

But I’m interested in trying HA to control more in the R2 and just bought a Home Assistant Green device to get started. In the forums on HA, it mentions you have to remove all devices from HomeBridge first then start installing HA so it recognizes all available devices during initial installation. Apparently there will be conflicts between the two if you don’t. And then it sounds like I can set HomeBridge back up within HA if necessary to control any devices that may not be native in HA.

Is this accurate? I’m hesitant to delete everything I’ve set up in HomeBridge (and that’s working perfectly) and start fresh in HA where there will undoubtedly be a steep learning curve. Can I just unplug the PI device where HomeBridge is running then set up HA or do I need to actually remove devices? Guess I could do a backup of HB, remove all my devices and then play around with HA. If it doesn’t work, reinstall from the HB backup and hopefully get back to current state.


I also just bought a HA Green but I’m having trouble getting getting R2 to talk to it. With the latest release I’m getting closer in that one of the screens shows HA’s entities but in the actual screen where you can use them nothing shows up.

If you get it working please post the steps you took. Thanks.

My Green arrived today and I just set up most of my devices. When you search in HA for Unfolded Circle or Remote Two, nothing shows up under integrations so I assume it’s not native/approved and we need to “side load” or something. Remember seeing a lot of posts in here about it so about to dive in. Will keep you posted on any wins and you do the same!!

HACS is your friend GitHub - JackJPowell/hass-unfoldedcircle: Home Assistant Integration for the Unfolded Circle Remote Two


I went to that article and tried to follow it and the first thing it says is to go to HACS within HA. Well, I searched HA and the closest thing I could find was the “Add-on Store” so I went there but could not find any info on how to find a custom repository. I’m running HA on HA Green so I wonder if my version may be different than other HA versions.

I did go to HACS directly but again i could not find any way to add a custom repository

Could you give me some help on this?

Hi Gerry,

Go to HACS, then integrations… search for unfolded circle… install…

HI Markk,

Thanks for your help, but for the life of me I still can’t find HACS. Here is a screen grab of my HA running on HA Green. It doesn’t look anything like your list of things. Is there some other list of things I’m just not seeing, but I have clicked on everything i can see and still no HACS.

Thanks again,

First point is to install HACS if you do not have it installed. Assuming you have installed HACS?

Hi Trial_Master or Markk,

Making progress but I still need some handholding! I installed the Terminal & SSH add-on and I could then execute the command at the top of the attached image. At the bottom of the image it seems to say that HACS has been installed. I did do a restart but I still can’t find how to actually access HACS. I was looking for a way to add HACS to the sidebar but i have been unsuccessful.

So i now have HACS installed but I don’t know how to access it! A little more help please!


Follow these steps next

It was like bumping around a dark room but I somehow ended up doing all the steps you all list above on my own last night and it worked!! HA seems to be up and running and I’ve added most of my devices. I was able to get my ecobee thermostat to appear and be controlled on R2 and all the HomeBridge devices were discoverable so I could control some of my lights from the remote. Very cool!

But my challenge is most of my lights/plugs are HomeKit native devices and none of them are available in HA. Through researching, I’ve realized I need to delete them from the Home app then set them up in HA where I can apparently then share back to HomeKit. I tried it with one device and it was discoverable and easily added to HA. And I could add it to R2 and control the light.

But I’m hesitant to go through that with every device and try to set everything back up from scratch in my Home app. All my automations, connections to Alexa, etc. The girlfriend would have no patience for that. She is already annoyed with my attempt to turn the house into the Jetsons.

I guess that’s just what’s required when you fully commit to HA and transition off HomeKit and HomeBridge. May take a stab at it at some point but may also wait to see how long it takes for the Matter integration to be released. I assume everything will port over natively from HomeKit (and HomeBridge) at that point with little to no effort.

But it definitely works and you can get access to most things for control with the R2. Again, VERY cool!!!

I have been able to install HACS. Connecxt to my GitHub account, but instead of the menu of items under HACS I get a single directory
repository Name
HACS, Downloads, Stars, Updated 13 hours ago, Category integration.
None of the submenu for further integrations, etc., most specifically trying to install the HAC UnfoldedCircle integration on the Home Assistant (not the HA on Remote Two

Home Assistant have their own community forums. Suggest general HA usage inquiries are posted there

Just go to the integrations section in HA now and search for HACS. There it should appear now so that you can further install…

That‘s because you have choosen for the experimental version of HACS… but that doesn‘t matter. Just search for Unfolded Circle in the upper search bar…

Markk or Trial_Master,

Guys, I am really frustrated! I followed all the steps to the letter and I now have HACS installed and accessible from HA. However when I search Integrations for Unfolded Circle It says “No repositories.” (See aattached image.)

What am i doing wrong. Please help!


… when you go into HACS and then into „integrations“ it should show a blue download-button in the right down corner… there it should work…

Hi Mark,

Thanks for replying so quickly!

There was a blue button at the bottom right which I did click on. I just didn’t include it in the screen image. When I click on it the only thing that comes up is the search bar at the top. In your screen image it looks like other things come up below the search bar. I’m getting nothing other than the search bar.

I tried searching for some other things that I thought might be in HACS like Amazon and nothing came up.

Do I need to set up some other permissions somewhere else?

Again, very frustrated and I really appreciate your help.


HI Markk,

My last screen image was wrong in that i did not click the blue button at the bottom right. However this time i did click the button and searched for Unfolded Circle but still got the same results (see attached)!


Then try this. Go to the upper right corner. There you see three dots. Enter… then you see something like „user-defined repository“ . Choose that and enter the following:“

1 Like