Integration Manager

That was it! Thanks so much.

I have the integration manager (1.5.3) installed on the remote. Config backups don’t work for me, e.g.

2026-03-12 10:55:45 web_server Backup failed for yamaha_avr_driver: ‘remotes’

2026-03-12 10:55:36 backup_service Starting backup for integration: yamaha_avr_driver

Any ideas how to look into this?

@JackPowell

Could your integration “speak” german or is it planed?

I’ve installed this, but I am unsure how it is supposed to work. I can navigate to the browser page (sometimes, mainly unable to connect) but it says zero installed integrations, as it does on the Remote 3 itself. Should it be detecting the integrations already on the remote, or do I have to add them manually? If it can’t detect them, how does it know what version i installed to flag the update? I’m likely doing something very wrong!

i don’t have translation support on the roadmap. Maybe one day

It pulls all that information automatically and immediately so something is wrong. If you have integration manager pulled up, take a look at the logs. It should give you a clue what’s wrong. You can share some of that here too if it helps

Did you enter the PIN of your web configurator during setup of the integration?

Ralf

Yes, the PIN was entered. I tried again around 22:12 this evening am getting a lot of log entries for the UC-Integrations set up, what is the best way to upload the logs?

I tried again today, and it worked :grinning_face: . I suspect this is more a stability problem with the R3 rather than an integration problem, I am never convinced it’s connected.

Great plugin just got a remote. For the oppo plugin I seem to be getting an error trying to install:

2026-03-30 22:19:07web_serverSettings page: UC_CONFIG_HOME=‘/etc/custom-intg/intg_manager_driver’, is_external=False

2026-03-30 22:19:00remote_apiFailed to check charging status: Authentication failed. Check PIN or API key.

2026-03-30 22:18:30web_serverLock released after SyncAPIError in install_integration for unfoldedcircle-oppo

2026-03-30 22:18:30web_serverInstall failed: Install failed: 400 - {“code”:“BAD_REQUEST”,“message”:“Binary directory not found”}

2026-03-30 22:18:29remote_apiFailed to check charging status: Authentication failed. Check PIN or API key.

2026-03-30 22:18:18web_serverDownloaded unfolded-circle-oppo-v0.0.20-linux-amd64.tar.gz (21767078 bytes) for install

Any help appreciated.

I’m trying to get this to run in docker on windows using WSL and portainer.

Other docker images are working fine.

I can’t seem to get the localhost:8088 to load

Config in portainer:

services:
uc-intg-manager:
image: Package uc-intg-manager · GitHub
container_name: uc-intg-manager
network_mode: host
environment:

  • UC_INTG_MANAGER_HTTP_PORT=8088
  • UC_CONFIG_HOME=/config
    volumes:
  • ./uc-intg-manager:/config
    restart: unless-stopped

Logs in portainer:

      

INFO:data_migration:No manager.json found - will be created in v2.0 format

DEBUG:ucapi.api:Publishing driver: name=intg_manager_driver._uc-integration._tcp.local., host=SERVER.local.:9090

INFO:ucapi.api:Driver is up: intg_manager_driver, version: 1.6.5, api: 0.6.0, listening on: 0.0.0.0:9090

Not sure what im doing wrong, 9090 will load in browser with:
Failed to open a WebSocket connection: invalid Connection header: keep-alive.

You cannot access a WebSocket server directly with a browser. You need a WebSocket client.

re: my question above

I am a bit confused I think, I want to run the brains of this from docker which is running but i cant get to the webui off docker on port 8088. Does this only show up once the remote is connected?

What does one do on the remote, I am assuming you still install integration manager on the remote and somehow get it to setup to the docker intergration?

  1. Get Integration Manager running in Docker.

  2. On remote add integration, it will find the external running Integration Manager and continue from there.

Both need to be running in same network.

1 Like

No install it either in docker or on the remote. Look into the docker logs perhaps it gives you a hint.

Independent where you install it each can manage several remotes.

Ralf

1 Like

But even when it’s running in Docker, you still need to add it as external running integration on the remote I thought?

Yep. This is correct for all integrations running in docker. Just like Eddy said, you still need to add it as an integration on the remote. (Do not select install custom)

1 Like

I have the integration manager running on remote now, but whats better? for integrations? docker if possible! or remote

Thanks for all the help yes I was going install custom, but really needed to go to install non custom, once I did that it connected to docker and webui loaded from docker. Much better than on remote where it was originally.

The big advantage by running in docker was the ability to easily update when I pushed a new release. But now with 1.6.7, integration manager can update itself when running on the remote. (You do need to manually update to 1.6.7 but from there on out you can just click a button to update)

I don’t know about “much better”, haha. But I’m glad you got it working.