Create a wiki on how to use/configure Remote Two

Just to be sure: Your Remote is in the dock when you try to access the web configurator? Try to use the real IP of the remote and not the .local domain. You can also try to change the dock domain to the real IP of the dock in the integration and dock settings. But keep in mind that the Ethernet and Wi-Fi interfaces have different MAC addresses and the IP will change if you switch between Wi-Fi and Ethernet.

Yes the remote was in the dock with power to it and ethernet connected. I have tried various options to connect to the web configurator using an iPad Air with the handset in the dock.

1/ Bluetooth & Wifi off on handset, dock connected to the mains and ethernet. No connection.
2/As above handset Bluetooth on. No connection.
3/As above handset Bluetooth off, Wifi on. No connection but I get a window saying that the Web Configurator is not available for this device. This cannot be correct as I have been able to connect previously.
4/ Disconnect ethernet from dock,
Handset Wifi only, same message as above.
Wifi & Bluetooth enabled, same message as above.
5/ Mains disconnected, same message.

The only obvious change since I was last able to load the Web Configurator is a couple of updates to the firmware on both the handset and dock.

I have looked at the Dock settings which tells me it is active. Relevant lines are;
Connection: N/A.
Service Name: UC-Dock and relevant number. Custom IP or URL: Not set, I can’t see a way to access this to make changes.
Firmware Version: N/A
Change WiFi settings: Not implemented yet.

I’m not sure where to go from here.

I have also tried using the URL rather than the QR code with the same results.

The message also appears if your browser window is to small. It needs a minimum size.
Another thing that could be mentioned somewhere since quite a few people including me ran into this issue before

Well I’ll be, I’d read the issues others were having with connectivity but don’t recall seeing that. Slid the side window out of the way and instant connection with ethernet connected, wifi and bluetooth. Why didn’t I think of trying that. Thanks so much progress at last, just got to work out how to integrate my Panasonic oled now!

So I’m gathering from these posts that a) the web configurator is turned off by default, with a slider switch that says “web configurator off” (but does it say "on) when you move it to on?) and b) something important is hidden at the bottom of a web page. I can’t know the details until I have played with the thing myself. I’m backer # 989, and will post to the “what backer #?” thread as soon as I get mine–I’m in the US. When I do, I expect to refer back to this thread, as well as the actual wiki, if it materializes before then.

When the web configurator is enabled the slider button moves to the right and contains a tick, similar with most enablers when set to on.

Since taking delivery of my R2 night before last, I have successfully installed the Apple TV integration. I installed the IR codes for "Oppo generic Blu Ray player. It turns it on and starts play, but does not stop. I installed the one for Emotiva generic AVR. It doesn’t power on. No doubt about it, I’ve got to learn some codes. But starting the procedure for that, it makes absolutely no sense to me I suppose it will eventually. That’s pretty scary, actually. I’m not sure I want my brain rewired so that it makes sense. Just kidding, Marton :slight_smile:

I have to keep reminding myself that I’m someone who loves music, likes movies and loves technology, especially in service of the other interests. I do this for fun. If at some point I find myself not having fun I take a break and listen to some music. Sometimes getting away for a while to cogitate helps me see what needs to be done. I hope others are doing this too.

i have a NOOB question about adding a device, such as a receiver or streamer. In Harmony, the command was – wait for it – Add Device. Then my remote had access to Logitech’s DB of commands, which was sometimes quite good.

What are the comparable commands/steps in Remote Two for adding a device and related IR codes? Note that I’ve already added all the integrations that UC has that I’m interested in.

Glad to read others have the same sense of befuddlement that I have. I am quite sure that Mssrs. Marton et al are overloaded, and writing manuals never seems to get a high priority. But I definitely need more setup info than what’s currently available. End of very mild rant.

1 Like

To add ir devices you go to the remote section of the web configurator. There is a + button you click on and then you can search in the ir database. The database has mostly generic sets for each device category from a manufactory and not an entry for each specific model like on a Harmony. But these should still include the same commands since most devices from the same manufactures and device class using the same code sets anyway.

1 Like

This makes more sense now. And so obvious. A “remote” is essentially a “device”, so that’s actually a good way to categorize this section. I was literally thinking it meant to add a new remote 2 or something. I’m dumb. Should be rocking and rolling soon. Thank you!!!

BlockquoteShould be rocking and rolling soon. Thank you!!!

Don’t jinx yourself by saying that! But yeah, I feel that I’m making some progress. My main problem at the moment is resisting the urge to spend every minute of my free time on this.

Yeah, I know the feeling. LOL. I have my first activity (Shield TV) configured and it’s working for the most part. Every button and sequence needs to be configured though manually it looks like. I enjoy doing that, and it’s easy, but time consuming for sure. I’m taking a break for a while.

You could use the Android TV integration for the Shield TV instead which works for the most part (except the ability to long press the OK button doesnt work yet on Remote Two)

I did use that, yes. Works great. And connects via WiFi instead of IR. Except for the long press like you just said. LOL.

I have been following along in the Discord server for several months, and I started a guide for my own reference. I received my remotes a couple of days ago, and am working my way through making the guide better, as I learn from my personal experience.

Unfortunately, I am stuck at adding integrations, due to an apparent lack of network discovery capability, but the guid at this link will be updated as I figure things out.

Thanks.

Mark

5 Likes

Could someone add the Discord Join link to the document and post it here also?

Hey Wotan,
I too create a remote on the R2 for my Emotiva RMC-1 using the generic Emotiva AVR setup. It doesn’t work for the RMC-1.

Were you able to program the IR codes to work w/your Emotiva product?

Have you tried registering on the Global Cache IR database and downloading from there? If you request verification, you can download the entire codeset in one go (as opposed to having to request 16 codes/day). Then you can drop them into a CSV and upload them.

You may also have luck reaching out to Emotiva support directly and asking for the PRONTO codes - they’re a pretty “nerdy” company, I can’t imagine they’d drag their feet about giving that to you.

The google doc mentions a mattgruter repository of IR remote CSVs. I see one available. I have 4 to contribute, but don’t know how to forward pull requests from the new github repository I created.

There is no place to simply drop files for others?

A place to drop 90x90 pixel icons would be super helpful also.