Create a wiki on how to use/configure Remote Two

Received my Remote Two this week. Thank you Unfolded Circle!
I am now slowly discovering all the features and making notes while I discover how to use the remote.
I wish to share my hints and tips with the community. What about a wiki where we can add the info?


+1 here.
I think this is a great Idea! So we can find faster solutions for our problems.



We definitely need a starting point, I had to read multiple comments/posts before I could find information about how to simply configure it as a basic remote.

The github wiki would be grate so we don’t need to make yet another account to contribute, and the team don’t need to find a wiki to integrate with the current platform. (just my 2 cents)

1 Like

Okay great I have found this thread. My issue is a lack of knowledge in the basics of setting up a remote like this, I have not come from a point of using other remotes or home assistant systems so the language is a little daunting, it would be really helpful if someone could explain in basic terms how to set up integrations and entities for the R2 as this is beyond my current knowledge and I can’t be the only one. For instance how to programme this remote with my Panasonic OLED tv.

Great idea, has anything been posted yet?

Some things I finally figured out:

The way to get to the setting tab/page on the remote is to press/touch the very top right corner of the display. Not understanding this took 1+ hours to figure out.

The “Web Configurator” is not enabled by default. The label on the remote settings page initially is “Web configurator disabled” and then the little slider/button is in the “off” position.
This can be interpreted as “web configurator disabled is off”, meaning it is enabled. This is poor UI/double-negative. The label should be fixed “web configurator enabled” and it is either on or off.

Once you get the web configurator enabled, and try to login in, it asks for a PIN. The PIN required is NOT the admin PIN you configured when setting up the remote!!! It is Web PIN provided on the remote on the settings page, when web configurator is enabled. Very confusing.

I do not yet understand the what a “Profile” is, a “Page” is, an “Entity” is, or a “Group” is. There realy needs to be short description of WTF these all mean, and how one should use them to accomplish something.

IMHO the out-of-box experience is terrible. I understand getting this out the door was extememly difficult, but there is no excuse for not explaining how to do “whatever the remote is capable of doing”, even if what it can do is not a lot.

A short “Getting started” writeup would take a few hours to write, as would a simple/crude YouTube video. Don’t worry about polished production quality, just record something with a webcam and post it.


Also, there should be some example “pages” or whatever that a new user could load into the remote, to see what it is capable of, even if the user doesn’t have any of those devices/entities in their own home. This would provide some context/examples of how it is capable of working, with a bit of config/work.

1 Like

There is a basic description of the user interface on GitHub:

Some tips from me:

  • Use the reset button in the ui editor above the button mappings column and the one under the grid to automatically let the remote choose which buttons fit best for the entity and create pages with most of the commands that the entity supports. This doesn’t seem to work that well when having multiple entities inside in an activity but it works for ir remote UIs
  • Tap and hold on the battery symbol to display the current battery percentage. This gets reset when you reboot the remote
  • Use the channel up/down buttons in the main UI to open/close groups
  • The admin PIN can be used if you create a new restricted profile. These profiles dont’t allow you to change settings on the remote. When you want to switch back to a non-restricted profile, you will be asked for this PIN. Warning - If you haven’t set the Admin PIN before you have to set it in the web configurator unter Settings, otherwise you can’t change your to your non-restricted profile anymore

Yes simple explanatory videos or procedural screen grabs would be very helpful for those new adopters like myself who don’t come from a relevant knowledgable background, it always amazes me that those with the knowledge assume that everyone else shares that same knowledge and don’t need a little help and instruction, I definitely do so it would be most helpful if the developers could put something together or any one else who fancies sharing their knowledge but in a simple manner.

1 Like

A Quote from Marton on Discord about the missing documentation:

We have a loooong list of documentation articles we need to write. Just trying to balance shipping,production,software updates.


Excellent that would be most welcome, however please bare in mind when doing so that not all backers/owners have the knowledge and understanding of the technical language as others do, please keep it simple.

1 Like

I have yet to receive my remote (hasn’t reached my backer # yet) but I’ve been braced from the outset for a steep learning curve. It’s sounding like my expectations will be more than met. I’m bookmarking this page because it seems to contain a number of helpful tips.

I second the motion for a one-stop “getting started” guide, with concrete examples, rather than just abstractions. Since a lot of users besides me seem interested in controlling a/v systems, at least one or two examples should be drawn from that area.

I spent some time a while ago downloading, setting up and reading the documentation for OpenHAB, which theoretically could be an interface for R2. I found it to be full of abstract terms, but little about how to do actual stuff with it. That experience, as well as my general experience with hardware and software engineers leads me to expect the same thing here: lots of enthusiasm for creating stuff, but relatively little for documenting it. That notwithstanding, I think at least some basic documentation should be given top priority on the “roadmap”. I’m hoping that when I get my remote I’ll at least be able to figure out how to learn IR commands that I’m already using on my Logitech, before the buttons finally wear out for good–crawl before you walk. Down the road I’m expecting the R2 to have enormous capabilities, once I’ve mastered them. But just a little something to help me minimize the amount of time spent banging my head against the wall would be greatly appreciated.

Yes I’m really excited by the potential for this remote but without basic “how to” information I feel that I have a rather expensive paper weight. I could work out the UI easily enough that is documented with the paperwork supplied and noted in the Github mentioned in an earlier post but that’s as far as I have got as there is no guide as to how to set it up after that. I have been able to make the connection to a Sonos Connect with the included integration within the remote software but now I’m stumped as I don’t know what to do next. I also seem to have lost the ability to make the connection to the web configurator which I could access on my iPad, it now just times out without making a connection. I have tried to follow other threads for information but have found that they do not really help me, rather they highlight my lack of knowledge and understanding in this area. Hopefully the team will get around to sorting some basic guides as soon as they can, I’m hoping that will not be to far away.

1 Like

Hello Sam1e,
Make sure the remote is on when your iPad tries to connect. Have you checked that?

See dcj’s first posting on this page, third paragraph. This may explain things, but I don’t know since I don’t have the thing in my grubby hands yet. Losing connectivity to the web configurator seems to be a common complaint. Don’t know why it would be off by default.

Sort of like the “silent mode on” switch on my iPhone SE. At least I have a hard switch to do this, though, which may be the last model to have one, which they can prize from my cold dead hands. But it shows how pervertedly alike some hardware designers’ thinking can be.

Yes the configurator is enabled, the dock is connected to mains for recharge and the ethernet connection is made, I have also updated to the latest firmware, still can’t get it to connect. When I initially made the set up connection was straightforward with no issue, no idea what has changed other than the recent firmware updates. I have not tried rebooting so will try that next.

I also remember reading that when the Ethernet connection to the dock is made it automatically disables Wi Fi. Don’t know if that’s significant, since everything just has to be on the same network infrastructure. just learning all I can and preparing for the inevitable initial frustration, which will hopefully not last too long. Just for grins, though, maybe try putting the dock on Wi Fi.

Do you think that would be the case if the dock is not connected to the mains but the ethernet cable remains in place? I can see that there is no communication at the dock without the mains connection to it. I will try disabling ethernet and leaving just the wifi, fingers crossed.

Just to be sure: Your Remote is in the dock when you try to access the web configurator? Try to use the real IP of the remote and not the .local domain. You can also try to change the dock domain to the real IP of the dock in the integration and dock settings. But keep in mind that the Ethernet and Wi-Fi interfaces have different MAC addresses and the IP will change if you switch between Wi-Fi and Ethernet.

Yes the remote was in the dock with power to it and ethernet connected. I have tried various options to connect to the web configurator using an iPad Air with the handset in the dock.

1/ Bluetooth & Wifi off on handset, dock connected to the mains and ethernet. No connection.
2/As above handset Bluetooth on. No connection.
3/As above handset Bluetooth off, Wifi on. No connection but I get a window saying that the Web Configurator is not available for this device. This cannot be correct as I have been able to connect previously.
4/ Disconnect ethernet from dock,
Handset Wifi only, same message as above.
Wifi & Bluetooth enabled, same message as above.
5/ Mains disconnected, same message.

The only obvious change since I was last able to load the Web Configurator is a couple of updates to the firmware on both the handset and dock.

I have looked at the Dock settings which tells me it is active. Relevant lines are;
Connection: N/A.
Service Name: UC-Dock and relevant number. Custom IP or URL: Not set, I can’t see a way to access this to make changes.
Firmware Version: N/A
Change WiFi settings: Not implemented yet.

I’m not sure where to go from here.