"State" question


I’ve posted a bunch here having troubles with IR remotes and such. I’m happy to report that I’m finally making some positive progress!! I actually made two whole activities and they kind of work! One is just watching TV with just the TV device in it and the other is watching DVR with the TV and DVR in it. From reading the posts I included them in a group so I can switch back and forth. Its working in that the TV switches inputs for the DVR and then back to TV and the power stays on for the TV when switching back and forth. But the DVR power is not turned off or on when needed and i have to do that manually.

I see that for the TV R2 shows a state that says it on or off but for the DVR it says “unknown.” The TV’s codes were a generic set that came with the R2 while the DVR I had to learn the commands from Pronto codes I got from an online IR database. The DVR does have a POWER command that I did assign to the power button for that remote.

Is there something else I have to do let the R2 know its state?

According to the activity groups knowledge database (Activity groups : Unfolded Circle Support) support for power toggle only devices is a planned feature.
As a workaround you can just create an additional POWER_ON and POWER_OFF command (name them exactly like this in upper case and with underscores) and use the normal power toggle pronto code for both of them.

1 Like

Hi Kennymc.c,

Thanks for the info and I’ll give it a try.

Another question if you don’t mind. How do I exit an activity? I can go back and forth between the two activities but how do I exit one of them without starting the other activity. I end up in the Watch TV activity and just want to shut things down but I don’t see how to just exit the activity. I have to power down the TV manually and the next time I use the remote its still in the Watch TV activity thinking the power is on and I have to manually turn the TV on.

Thanks again,

Hit the “power” hard button in the bottom right corner.

Hitting the power button didn’t work.


I tried setting up the POWER_ON and POWER_OFF commands both actually the codes for Power-Toggle. I set them up as test soft buttons in the DVR device remote page and confirmed that either one would turn on or off the DVR. So I put them into the startup and ending sequence for the WATCH DVR activity and I’m still not getting it to work. I had more time to investigate and found something interesting. On the DVR’s display anytime it sees an IR command (even if it is not for the DVR) there is a small white blink right above the clock display. When I go into or out of the WATCH DVR activity the only thing in the sequence for the DVR is the power commands and I DO NOT see the little blink meaning no IR command was sent at all. So i wondered if there was some limitation when sending sequence of commands to the DVR however i did make 2 macros to go to a certain channel on the DVR which works perfectly and they are just a sequence of commands.

Going back and forth between the WATCH DVR and WATCH TV activities the TV has to switch to HDMI2 for the DVR and TV Tuner for TV and those commands are in the startup and ending sequences of the activities and they work perfectly.

Any advise would be appreciated!

Thanks again,

Hi @gerryex in your activity, did you assign anything to the hard power button? If you did, I would imagine that this would override the activity shutdown.


Son of a gun, IT WORKED! Is that written up somewhere? I saw a writeup about activities which explained how switching from one activity to another will take into account which devices were already on, etc. But there was no mention of how to just exit an activity. I had the TV’s Power Toggle assigned to the power button just in case I had problems but when I cleared the power button and hit it while in the TV activity it exited the activity and left me at the page where i have the activities listed which is exactly what I wanted.

Thanks again,

1 Like

There should be a warning message popping up in the web configurator if you try to re assign a system button like this. This also happens for other buttons like the home or back button.


I agree. I did want to use the BACK button the way i wanted and did get a warning but made the change anyway but when i assigned the POWER button to something I got no warning.


Yes, I also noticed this now. Since the warning message is referring to the navigation functionality I assume it is expected to not show it for the power button. But I think it would make sense to also show the message for the power button. You could create a feature request for this.