Roku device discovery

Has anyone had success integrating with Roku devices? When going through the integration setup, no entities seem to be discovered and the entity list remains empty no matter how many times I delete and reinstall the integration. There is also no option to manually add any Roku devices. Interestingly, when doing a packet capture, I also don’t see any MDNS or SSDP discovery traffic while going through the setup steps. The code for this integration doesn’t appear to be public so I can’t be sure what to even look for.

I am not the guy to help troubleshoot. All I can do is confirm that my experience matches yours. It says its finished integrating successfully, but there is nothing to work with. See below:

The process asks the user to provide “entities” but I am offered no choices. So, other than feeling your pain and confirming your experience, I can’t offer much. :slight_smile:

I have been able to connect to my Roku Ultra. It just seemed to work…

And I was able to create an activity

SOLVED: After updating to 1.4.8 this morning, Roku Ultras are able to be detected by the integration.

my Remote 2 also can`t find my “fake” Roku (a IOBroker instance which is working with my Harmony) . Even with 1.4.8


Would it be possible to enter the IP or hostname of the Roku player manually instead of using - well what is used to determine the player… zeroconf, dlna, broadcast? - that detection algorithm? I assume detection is a bit more complicated in some home network setups than just the simple control via TCP/8060. So for me it would be an extraordinary good option to enter the connection information manually like e.g. in the Home Assistant integration.

I’m in the same boat as others and cannot autodiscover my Rokus. Of course, I can pass control through Home Assistant, but that adds delay to every button press…

Autodiscovery is great in ideal conditions, but there are a number of factors that can keep it from working. The user absolutely needs to be able to manually define the IP address when adding a device.

I opened an issue for adding roku manually: [feature request] Roku integration enter IP manually · Issue #240 · unfoldedcircle/feature-and-bug-tracker · GitHub
To add my disclaimer: While I’m generally expecting a 400EUR remote works from the beginning, I bought that device mainly to support the open source mindset of unfolded circle. Openness is a must for Software and Hardware as well.
So I’m currently not harming the developers for the partially unfinished software and wish you all the best for the future development of this great product. An dedicated roadmap with a transparent communication from the team exists, so I have no doubt that the software quality will end up in the same level of perfection as the hardware. Thanks for your effort and stay motivated! Merry Christmas :santa:

1 Like


Add me to the list of not being able to discover my Roku. My Roku is hardwired into my network but it still could not see it. One time I got the rotating circles and was hopeful it would work but alas it still did not detect it. Hopefully some new firmware will fix it!!


Same problem for me. But, with 1.53 firmware, I had set up Roku and it had detected my Roku Ultra kit. But after upgrading to 1.60, I noticed the Roku activity no longer worked. Then I noticed that the Entity had disappeared from my setup. I can’t say the upgrade caused this; could be coincidence. Or it could be the effect of a 10-hour power outage. :slight_smile:

Update: just installed 1.61, re-ran Roku installation, and it discovered my kit. Thanks!

I have a Roku Ultra and the couple of times I tried to have it discovered it wasn’t found. This was before the latest firmware. So, I decided to just control it via IR and it works just fine. Maybe with the new firmware it could be detected but since its working with IR, I’M NOT TOUCHING IT!!!


Backup the remote, and test. You can always restore the backup.

my FakeRoku of Roku2MQTT Docker is also not detected:-(


I’m in the same boat on 1.6.7.

I can install the integration, but no entities are found. What’s odd is when I first setup my remote yesterday, I updated the remote from 1.4.X, installed the integration, and the remote found all of my Roku devices. The key pad buttons worked with my Rokus (eg left, right, select, play/pause), but I wasn’t seeing any info related to my Roku on the remote screen – just a generic placeholder saying something “nothing is playing” or something along those lines. I couldn’t get activities to work with Roku either.

I deleted and reinstalled the integration without any luck. Also tried resetting the device and factory resetting to rollback the software update. Ever since then the integration won’t discover any of my Rokus.

I spotted “Unhandled rejection Error: No sockets available, cannot start.” in the debug log. Might be the culprit but I’m not sure.

2024-02-05 23:06:47.840111 +00:00	intg-roku	INFO	There was an error during Roku device discovery: Error: Could not find any Roku devices after 10 seconds
2024-02-05 23:06:37.850155 +00:00	intg-roku	INFO	    at init (/opt/uc/integrations/roku/driver.js:417:8)
2024-02-05 23:06:37.850155 +00:00	intg-roku	INFO	    at discoverRokus (/opt/uc/integrations/roku/driver.js:297:26)
2024-02-05 23:06:37.850155 +00:00	intg-roku	INFO	    at Function.discoverAll (/opt/uc/integrations/roku/node_modules/roku-client/dist/client.js:63:27)
2024-02-05 23:06:37.850155 +00:00	intg-roku	INFO	    at Object.discoverAll (/opt/uc/integrations/roku/node_modules/roku-client/dist/discover.js:112:12)
2024-02-05 23:06:37.850155 +00:00	intg-roku	INFO	    at new Promise (<anonymous>)
2024-02-05 23:06:37.850155 +00:00	intg-roku	INFO	    at /opt/uc/integrations/roku/node_modules/roku-client/dist/discover.js:134:16
2024-02-05 23:06:37.850155 +00:00	intg-roku	INFO	    at RokuFinder.start (/opt/uc/integrations/roku/node_modules/roku-client/dist/discover.js:68:9)
2024-02-05 23:06:37.850155 +00:00	intg-roku	INFO	    at search (/opt/uc/integrations/roku/node_modules/roku-client/dist/discover.js:62:25)
2024-02-05 23:06:37.850155 +00:00	intg-roku	INFO	    at (/opt/uc/integrations/roku/node_modules/node-ssdp/lib/client.js:82:17)
2024-02-05 23:06:37.850155 +00:00	intg-roku	INFO	    at SsdpClient.start (/opt/uc/integrations/roku/node_modules/node-ssdp/lib/client.js:54:10)
2024-02-05 23:06:37.850155 +00:00	intg-roku	INFO	    at new Promise (/opt/uc/integrations/roku/node_modules/bluebird/js/release/promise.js:103:10)
2024-02-05 23:06:37.850155 +00:00	intg-roku	INFO	    at Promise._resolveFromExecutor (/opt/uc/integrations/roku/node_modules/bluebird/js/release/promise.js:518:18)
2024-02-05 23:06:37.850155 +00:00	intg-roku	INFO	    at Promise._execute (/opt/uc/integrations/roku/node_modules/bluebird/js/release/debuggability.js:384:9)
2024-02-05 23:06:37.850155 +00:00	intg-roku	INFO	    at /opt/uc/integrations/roku/node_modules/node-ssdp/lib/client.js:60:10
2024-02-05 23:06:37.850155 +00:00	intg-roku	INFO	    at SsdpClient.SSDP._start (/opt/uc/integrations/roku/node_modules/node-ssdp/lib/index.js:229:10)
2024-02-05 23:06:37.850155 +00:00	intg-roku	INFO	    at SsdpClient.SSDP._createSockets (/opt/uc/integrations/roku/node_modules/node-ssdp/lib/index.js:186:11)
2024-02-05 23:06:37.850155 +00:00	intg-roku	INFO	Unhandled rejection Error: No sockets available, cannot start.
2024-02-05 23:06:37.785964 +00:00	intg-roku	INFO	Starting Roku device discovery.

I am on 1.6.10 with this issue as well.

I have tried restarting the controller several times to resolve the issue as well.

My current workaround is to use the home assistant integration that can control the Roku too. The issue with that is that I cannot sent the arrow keys via that so it’s dead in the water to me.