Remote doesn't charge

My dock doesn’t seem to charge the remote. I tried the supplied cable, other cables and various chargers (all meet the requirements - OnePlus 9 Pro, Aukey, Samsung). Does anyone else have a similar problem? @marton Any ideas?

So I pulled the whole display unit out of the metal body, cleaned the contacts of the board inside and tried to press it back into the metal body as firmly as possible. Seems to have sorted my problems out, it’s charging. Let’s hope it’s not just working for now.

I’ll leave the thread open for future reference if anyone runs into the same problem. Also thanks to Marton for getting back to me quickly with instructions.

Find the steps below:

  1. If you have a pen or a sim ejector tool, you can push that in the back in the hole, then pressing down and up on the buttons will slide the internals out. Actually this is the process for replacing the battery.
  1. Then sliding back in the subassembly should reset the location of the pins. Just make sure to push the pogo pin down on the back as shown here, otherwise it can break.

Cmon, let us see the videos :grin:

They are private.

Marton and team are working on official guides with video for some issues. Stay tuned!