Problem with ON sequence due to delays commande


I have two devices that take between 1:00 minutes and 1:30 minutes to turn on, and I have to send them commands once they are on.

But my UC remote2 is stuck with such long delays and never gets to the end of the sequence.
Do you have a solution?

because I imagine the best thing would be to program everything with HA, but I don’t know enough about it.

I do not kow most of the devices but at least I would remove all “Press innov input shield” and leave only the last one.

I would also put a delay between each step. I found 300ms works well.

thanks for your feedback,

I tried with this:

but the problem remains the same, when I have a long delay, like my 40’000ms, the remote gets stuck at this stage and doesn’t execute the following tasks.

Are those devices old CRT TVs or valve amplifiers? I can’t understand why they take so long to power up.

If the don’t have a Sleep command as opposed to Power Off, you might consider leaving them permanently turned on.

As to why the R2 hangs, is it timing out while you wait 40 seconds? You should ask @marton about this.

difficult, Bragi it’s a projector so I don’t want to leave it on all the time. and I have to give it 2 commands:
1st: WOL to wake it up (this takes ~1:30)
2nd: to turn on the lamp
and Altitude is an audio processor, but in reality it’s a computer, so it’s time to turn it on (this takes ~1:00)
then I have to select the input I want to use

Hi Harvey,
leaving devices in standby is a very simple solution but to simple. Old devices, projectors and Android-/Fire-TV devices need some time in certain cases. I have a similar timing problem at the moment.


60 seconds seems to be the current maximum: Delay in Activity does not support more than 20 seconds. · Issue #137 · unfoldedcircle/feature-and-bug-tracker · GitHub

Do you actually need to set the input on the projector each time or does it ever change? I would assume you’re using the Trinnov for video switching, but perhaps I’m wrong?

My JVC projector is always musing input 1, so I never need to send an input command in an activity.

Me too. My AVR does the input switching and projector only on one input.


thanks for sharing the link

It’s not an old projector, on the contrary, it’s very high-range.
But it takes a long time to power up, and the second command I have to send isn’t to select the input, because that’s where it stays in memory, but it’s to give the command to switch on the lamp (the first command just gives the command to wake up the projector).

However, if I’ve understood correctly, there’s currently no way to use the remote2, so I’ll have to learn to use HA instead.

Thanks for your help

1 Like

Idea: Create 2 activities:

  1. only wake up the projector no end sequence.
  2. real activity to use the projector.

Both must be in the save activity group. Now 1. start projector, 2. make a drink, 3. use the projector.

No need to learn to use HA until there is a better solution.


indeed, it can be a solution,
Thanks Ralf

Does the Barco have IP control? If it does, and there’s a Home Assistant integration (or you can write one yourself), that could very well be a good solution.

For example…I have my Lumagen power on/off tied directly to the power status of my JVC projector in Home Assistant. 99% of the time I only need Lumagen to turn on and off. I do have the control to make adjustments on a page of the remote in my activities, but I rarely need it.

If you can have Home Assistant listen for a power status change on the Barco, and when it senses that power on, wait for 120 seconds and then send an IP command to turn on the lamp, that would solve the problem quite easily.

It looks as if this could be a framework to build upon in HA.

@Thrillcat, indeed, it’s a really good idea
I’m going to follow this idea

1 Like