New Android TV commands - beta firmware 1.7.10

Hi, so I just installed the latest firmware (1.7.10) yesterday, going from 1.7.7 and I have to say the plethora of Android TV commands in the latest integration is amazing! I am/was finally able to set the long press enter/center button to act like it does on the shield TV remote. However, it only worked for like an hour. All of the sudden these new commands are missing. I can’t assign any of these to a physical button anymore. The function keys (F1, F2, etc), long press home, and a bunch others are no longer listed. I’ve reinstalled the integration and tried everything, but I can’t get them back for some reason. Does anybody know why?? I’d appreciate any insight!! Thanks.

How did you get this firmware? I signed up gor beta updates as well, but my Remote does not show anything newer than 1.7.7

After that you must restart the R2

It showed up in my remote settings a couple nights back.

Try rebooting the remote and then checking.

I have this beta firmware - how do I add these "new"commands such as the long press?

Its been so long since I actually used this remote that I forget.

NEVERMIND - Worked it out!

Great!! But you’re seeing the new long press option for the shield TV? Are you also seeing the function buttons?

Indeed, rebooting the remote did help. Thanks for the hint :slight_smile: