Losing Connection To Dock - Still a Problem

I know this subject has been discussed in several other threads but wondering if 1) anyone else is still experiencing it and 2) if anyone has figured out a solution.

My remote is set up and working great. I’m ready to retire the Harmony Elite and move the family to the R2 but this doc connection issue is a huge problem. I use the dock and emitters for IR and it works perfectly. But, after any lapse in activity, I pick the remote up to change the channel or mute the volume and it won’t work. I get the red warning error message at the top saying “Unable to connect to dock” and no IR commands can be sent.

It happens pretty much every single time the remote has been idle. Sometimes it only takes about 5-10 seconds to reconnect and start working again but lately, it can take up to 10min for it finally to reconnect. When I go to the home screen, I see the WiFi icon with a red line through it so I know it won’t work until that goes away.

If I change the setting to don’t sleep during activity, it solves the problem but the battery won’t last a day. So I set it to not sleep for 15min hoping there is some remote interaction while watching TV that keeps it awake. I changed my Dock to Ethernet connection and used the IP address but that had no impact. I changed the charging cable and used a more powerful charging brick to see if that would help but no luck. I thought about changing the IR to come from the remote but the throw distance is pretty short and some of my components are not line of site.

If pretty much every time someone picks up the remote and it won’t work for anywhere between 5sec and 10min, that is obviously a deal breaker. The family will never use it. Is anyone else still experiencing this problem? Has anyone figured out another solution other than the ones I detailed above? I keep hoping this is something that can be fixed in a software update as it basically makes the remote useless but I haven’t seen a big outcry recently on this forum. So I’m thinking it might just be my setup or remote unit/dock.


I have almost the same problem but it is not limited to the dock :

  • it takes usually 5-10 seconds after idle to process commands again (red popup or dock connection)
  • it also take the same time to process lan commands (home assistant, Apple TV…) and they are handled by the remote itself so idle is only on remote part
  • it will never take more time : i never’ have your WiFi disconnected logo. Maybe you should digg this around your WiFi system (mine is a deco Mesh WiFi 6E)

Anyway I agree this delay is a big deal : with Harmony elite it took 1-2 seconds to start processing commands after idle and it was already annoying.
At least the command should be queued and processed when the connection comes back and wake up from idle should be faster.

The goob alternative will be Bluetooth pairing … when it will be available, as the connection will resume very quickly

Otherwise meantime I set sleep to the max duration : 30min and this limits the problem
But I put the remote back to the dock after each use. You can’t let it all the day on a table or the coach.

Yes, I still get this error as well.

I have no solution other than to wait it out.

My dock also lost its WIFI connection yesterday. Did a reset, still no luck. Think it has something to do with the latest firmware update. It only shows up after a reset, but after entering the WIFI SSID and passcode, you get an error.

With a fixed ethernet connection it still works.

Strange this issue is not apparently affecting more people. My setup is relatively straightforward as I’m only looking to control a TV and DVR from the cable company Xfinity. The dock and IR blasters work perfectly controlling both devices but the remote can’t seem to simply stay connected to the dock over WiFi.

The dock is connected via Ethernet and I entered the manual IP address of the dock in the web configurator. It just seems impossible for the remote to maintain a constant connection to the dock which renders it basically useless.

I went ahead and just changed the do not sleep timeout to 30 minutes and that helps as the remote is most likely jostled (and wakes up) at least once every 30min. But the battery doesn’t last a full day with that 30min timeout setting. So, again, renders the remote useless.

Hoping this is something they can fix with an update or, based on the fact others don’t seem to be having this glaring problem, maybe it’s just has to do with my wifi network or something?

I don’t experience that issue. The only hub/remote communication issue I have is if I pick the remote up and start using it without waiting a couple of seconds.

I have my settings tight to preserve battery.

Display timeout = 10s
Sleep timeout =1m

UC seems to be plan to improve the re connection time: Speed up dock & integration connection logic · Issue #320 · unfoldedcircle/feature-and-bug-tracker · GitHub

Thanks for pointing that out! Great to see they’ve recognized the bug!