Have to reboot to use Apple TV

If I want to use the remote for AppleTV I have to restart it every day.
Before I reboot it goes to Apple TV but no buttons are working.


This is a documented bug that needs to be addressed in a firmware update (and UC is being very unresponsive to). All three of these issues are inter-related:

  1. [bug] AppleTV - internal error please try again later · Issue #315 · unfoldedcircle/feature-and-bug-tracker · GitHub
  2. Buttons Unresponsive · Issue #176 · unfoldedcircle/feature-and-bug-tracker · GitHub
  3. [bug] Physical buttons not always working (not hardware related) · Issue #237 · unfoldedcircle/feature-and-bug-tracker · GitHub

You can add to hopefully solving this by adding your logs to one (or all) of those Github threads.


I’m a new and not very good at those things but I’m willing to help.
How can I find and or generate those logs?


Same happens in my system. It has gotten so predictable, that now I simply reboot the remote the second I take it off the dock - EVERY TIME. Sure wish this would get addressed.

It’s the same for me now. Interestingly, I hadn’t perceived it that way a few days ago, but in the last few days, it has become increasingly noticeable. By now, I reboot the R2 daily. A few days ago, I observed the same issue with the SONOS integration, which is why I switched to controlling SONOS via Home Assistant. Now, it’s somewhat similar with the Apple TV integration.

As it stands, the R2 is purely a DIY project for me. It’s completely unsuitable for the family, and so I’ve put my Logitech Harmony back into use. All in all, I’m now hoping that the next firmware release will bring an improvement in stability. That would be the most important point for me, as fundamentally, the R2 works for my setup.

I have noticed a similar problem this weekend after I rebooted the ATV. But before and after this I had no problems.

This is really strange as I don’t have this problem. I do have random stabilities issues but not every day. Your Apple TV is connected through WiFi or Ethernet ? Mine is Ethernet. Have you tried to set up a fixed IP for your Apple TV ?

And as stated above I never reboot it

Ethernet (two of them and both exhibit the same issue requiring reboot). I haven’t tried static IP, but will try it to see if it resolves.

Have you tried to add multiple Apple TV instances to your remote ? I have 2 but chose to pair just one as this is not supported
Also I don’t know if it changes anything but I set up timeout to 30m even if it drains battery

I am also in the same boat. Makes this thing completely unusable for the family.

Hey there.
I also suffer from this issue, here is my work-around: I use the Infrared-Codes as long as the bug is not solved.
The Codes are available as “Generic Apple TV” in the settings of “Remotes”.

I wonder if this has something to do with the pin-pairing that the AppleTV requires for peripheral controls…

Have you found success with the play pause toggle? The command does not seem to work.

For most instances the enter-button does the job in the same way. There are some occasions where this does not work, but in the popular services (Disney+, Netflix, DAZN, prime…) it works fine.

Also I took my original remote and recorded the signal via the dock, this way it worked, too.

Hope this helps.

Surprise … new firmware and no fix for this.

Edit … to be fair, I may have misspoken. I reran the integration setup (didn’t delete and re-add) just went through the first steps and it may be resolved. Will do more testing. If it’s fixed, I’ll post a follow up.