Fritz!Box routers and mDNS

I’ve just got my Remote Two and have been trying to add the dock.
My Remote Two is successfully connected to my Wi-Fi, which is a mesh network created by a Fritz!Box 7590 with a 7490 as a mesh extender.
Whether I connect the dock via ethernet, or try to connect it via Wi-Fi, it fails with “Connection refused”.
According to the UC network requirements, the remote and the dock rely on mDNS to talk to each other.
I have found an online discussion elsewhere that claims that Frit!Box routers “do not talk mDNS”.

Is there no way to make the dock work with my current network ?
Does anyone have any suggestions or recommendations, please ?

I feel your pain! Just went through this myself. Disable any 5G bands, and pause your firewall and any VPN temporarily. If you can find the remote and dock in your router IP table, assign a static IP for each, reboot the remote, turn on the web configuration option and try via Chrome.

Once you can access the web configurator in the remote, leave it in the dock so it doesn’t time out too quickly, add the dock via a MANUAL entry (IP address) and you should be OK.

Don’t forget to update your firmware on the remote and dock!

Have a look here…

Thank you Hammerhead ! That got me to the point where I could add the dock.
Unfortunately, as soon as I tried to put my network back in the state it was before, neither the remote nor the dock will connect to Wi-Fi.
Because we have security cameras on our network, I can’t leave 5GHz turned off permanently. I also can’t turn off the mesh extender permanently.
It looks like all I can do at this point is to buy another router and connect it to my 7590 router by ethernet, and then create a new WLAN exclusively for use by the RemoteTwo and the dock.
If anyone is out there and has managed to get theirs working with a Fritz!Box I’d be very happy to hear from them. :sweat_smile:

I have a FritzBox 7530 with 2.4 and 5 GHz bands enabled and have none of the issues you describe. So whatever the root cause may be, I doubt it is related to the band or being a FritzBox.

Same here… I have a FritzBox 7590 AX with 600 and 1200 AX as mesh extenders and 2.4 and 5 GHz bands enabled and also have none of the described issues. But I configured the fixed actual IP addresses of remote and dock in configuration.

Thank you Leo and thank you Sturgis.
Now that I know that you are successfully using FritzBoxes (Fritxboxen ?), I will try to diagnose whatever else might be causing the issue.
The remote connected easily, but the dock has been the problem.
I have the remote as a fixed IP address. I also fixed the address of the dock when it was connected by ethernet. It’s the Wi-Fi for the dock connection that seems to be the problem.
I’ll try everything again !

Did you configure the remote and the dock with their actual IP adresses? Don’t use the mDNS name. And please think about to use the dock WIFI IP adress, which will differ from the ethernet IP adress.

Thanks Sturgis. I’m not trying to use the mDNS names.
I have the dock working if connected with ethernet.
I can use the remote and the dock is sending IR signals.
If I were to leave it on ethernet, it would be very difficult to get IR repeaters to all of my devices.
I might have to wait for the enhancement that allows the remote to send the IR signals.
The dock still won’t connect to the Wi-Fi. It just flashes the white LED all the time.
I can’t understand how to use the dock Wi-Fi IP address because it has never had one ! The router has never seen it.
I’m going to take a rest and come back tomorrow. Thanks for your help.

You can send already the IR signals via the remote. With firmware v1.5.2 it’s possible, but you have to activate this in the R2 settings in web configurator. Go to:
settings > develop > preview-functions
(the English menu names maybe differ, because my web configurator language is in German)

If you can see both the remote and the dock, you should be good to go. Just use the manual configuration in the remote and enter the IP of the dock. it might take a power cycle or two. I found that something was getting ‘stuck’ and that after power cycling both the remote and the dock, the next morning I could access both.

Thanks again Sturgis & Hammerhead.
I went through several more cycles of powering on/off the remote and the dock, and suddenly the dock connected to the WiFi.
Both are now connected via my mesh extender 7490, so it seems I was needlessly worrying about the warnings not to use a mesh network. I was chasing a red herring :sweat_smile:
Now all I need to do is learn or download a whole lot of IR codes.
Thanks !!

1 Like