Delay accessing home assistant entity

I imported a home assistant media player entity (AV receiver) in RC2. It works pretty well so far : I can control the volume and a progress bar displays when it changes on the screen.
However when I don’t use the remote for a while, it takes ~10 seconds to handle the commands (up/down volume in my case) again.
Is it a problem on RC2 side or homeassistant (webhooks) ?

Thank you

In web configuration, is it possible to set that activity to “stay awake”?

I’ve done that for my watch tv activity, that keeps the remote out of deep sleep.

That definitely solves the issue mentioned, but the battery drain is horrendous. Be good if hub could do more heavy lifting like Harmony Elite.

Thanks for the tip but I fear for the battery drain too.
Otherwise after changing the hostname to the IP address into the home assistant integration, it seems that the reconnection is quicker. Te be confirmed…

I just got mine setup this weekend with HA as the only integration. Unless I want to wait over a minute to pause something (which is obviously not ideal) I had to set the activity to not let the remote sleep. With that, I get maybe 8 hours on the battery. I mean, I guess that’s OK given we generally don’t watch more than four hours or so of TV a day, but it means the remote basically has to live on the dock so that we I do decide to watch something I can pull it out and not have to wonder if the battery will live long enough to get through.

There’s stuff in this remote to like, but compared to my Harmony remote, which has one of those flat “watch” batteries and only has to be changed maybe once a year, this thing is awful. I also wish they had put more of the brains in the dock and had the remote just be a thing that forwards commands to the dock, but I suspect given all the engineering and programming time put in already on this design philosophy, that will probably never happen.

My delay is 1-2 seconds to wake. Something not right if you are waiting over a minute.

Oh, the remote “wakes” up almost immediately. It’s just that none of the buttons do anything for 30 - 60 seconds. Without some way to do debug logging on the remote, I can’t tell what is happening, but I can tell on the HA side that absolutely nothing is received from the remote. If it’s anything like the connection ESPHome makes, that makes sense since it takes 30 seconds from wake from deep sleep with an ESPHome device before the API connection is established.

I can only assume that by keeping the remote from going into deep sleep, whatever connection is made between the remote and HA stays active too.

I see, the only HA entities I’ve used so far are WoL and that is pretty much instant when I start the remote activity, I also have a motorised curtain that has a delay, but more like 10 seconds.

I’d like to stop the remote sleeping and might go back to it, it’s much easier to pick up and use straight away. Might be worth charging every night. Undecided still.

On my side it is about 10 seconds delay too when the remote has to reconnect.
I replaced the hostname of the dock by its IP address in the remote settings and configured a fixed IP from the router. And the same for home assistant integration.
It is quicker to reconnect then, but not enough though (10 seconds…)

You have a fixed IP on your router for the HA integration? Where do you see that? I have a fixed IP for R2 and my HA server.

Yes when you setup the HA integration just right here :

Just nslookup command from your pc : “nslookup homeassistant” to get your IP
Just replace homeassistant.local with your IP address. I didn’t want to set it up all again so I made a backup, opened it with 7zip and modified the integrations\hass\config\home-assistant.json. Then I restored the modified backup file and it was fine.

1 Like

Cool thanks for that.

All done, nice and easy. Thanks again.