Custom app/URL - new FW

Ok, I must be blind or dumb. How the heck can I add a custom URL to launch an app with the latest firmware??? I’m trying with my Nvidia shield, but choosing input source as the command doesn’t give me any way to customize the app value. I can only choose from a list of predefined apps. Anybody??

EDIT: Just start typing where the text would be to the right of “source” and either click the ADD option or press enter. By the way, this is awesome. You can launch any app that exists. To find the “URL” text needed, go to the properties of an app under settings and the command will be whatever the internal app name is. For example, Fandango Now would be “”.

Did you try just typing in the URL instead of selecting from list? In my case I got a popup with ADD so I assume this entry is then added.


OMG. Yeah I thought I tried typing before, but now it works. Thank you!!

I’m getting the app details screen with the option to enter “open”, not opening the app directly. I have a macro to do that, but any idea why the apps won’t open using the app name. The two I am seeing this with are Crave TV (ca.bellmedia.cravetv) and BritBox (

Because not all Apps can be started the same way. Here some samples of current ones:

"ARD Mediathek": {"url": ""},
"ZDF Mediathek": {"url": ""},
"Kodi": {"url": "market://launch?id=org.xbmc.kodi"},
"1und1": {"url": "1und1tv://"},
"Arte": {"url": "arte://display"},

If the App is in the Playstore
should do but you need an internal name not simply Kodi in this case.

what did you try?


I just used the apk name from the play store … eg. ca.bellmedia.cravetv …if I change the string to “market://launch?id=ca.bellmedia.cravetv” I get the same result (takes me to the details screen). If I try the simple url for the website, I get “try again”.

Take a look with Package Browser to see if you find more information. Sometimes it takes quite some research. I spend hours on some links. Sadly Goggle did not include a proper way to detect installed Apps like Apple did.

One tip: Start the Android TV device, not activity, you get an almost black screen with an input selector and the currently running app. Start FandangoNow and look what´s shown on the display.