Changing activity doesn't turn the other activity to off


I have setup two activities.
I noticed when switching between them, the both turned on.
Is it possible to turn the previous activity to off?
And if beïng noticed that activity 2 also is using the TV, to leave the TV as is and only turn off the Media decoder?

Kind Regards,

You need to create an activity group and then put your activities in the group. Once this is done, they should switch and detect power states…assuming you have the latest firmware.

See here…Activity groups : Unfolded Circle Support


I can see the logic in this.

Unfortunatly doesn’t work yet. When switching between the activities, the previous activity still staying in the state On.
So both activities are On.

It will only work with discrete power on and off commands and these will need to be named POWER_OFF and POWER_ON.

When you have a device with a power toggle then create two custom commands with these names and assign the power toggle command to both of them

How are you assigning your activities in the user interface? Are you actually making a group? If so, try just adding them one by one to a screen instead. I think if you have an actual group on the UI, this won’t work properly. Also, make sure in the web configurator of your “activity group”, check the drop downs on the left for the state behavior. Just make sure they’re on the default settings for now.

1 Like


Unforunatlly the problem isn’t resolved yet. When 1 activity is on, and I turn the other activity to on, the other also stay’s on.

The configuration at this moment is the following.
I have replaced the Power IR coded with the correct names, Power_ON and Power_OFF and used these in the activity sequences.

At the moment there a 2 activities.
Number 1 has the devices, TV, media box and Sonos, Number 2 has TV and Sonos.
Both activities are working correctly when turning them on of off.

I have created on the activity page an Activity Group and placed both activities in this group.
In this group I have set for turning off unused devices to Always.

On the UI I have added both activities on the same page, and there is nothing else at this moment on this page.

I hope some can tell my what goes wrong here.


Change in activity groups the off command to “In off sequence” instead of “always” and write POWER_OFF and POWER_ON in big letters. That resolved the problem.
I also have a 1 second delay in the off sequences in every activity between the different devices.

You need to have complete and separate activities. I.e., #1 activity turns everything on and turns everything off. #2 activity turns everything on and turns everything off. The power state logic with the activity groups automatically skips any of those “initial” commands and then just switches an input or turns off an old device from the activity that is switching off and turns on anything new switching on. Sorry, hard to explain. But it should work. Make sure the power off and on commands are in caps. Not sure of that matters though. Make sure your activities are MEMBERS of your activity group. Make sure the default settings in the activity group are setup. Do NOT use a group on your user interface/screen. Put them separately on the screen.

I am also struggling to get my head around this one. Multiple activities in my activity group are stated as on at the same time.

Another part I am not understanding is the POWER_ON naming. I have a Marantz AV receiver so I am using the Unfolded Circle Denon integration. The on command for this integration is called “Switch on”. Am I supposed to rename this to POWER_ON, and how do I do that?

I have tried @Tobbes suggestion and changed the Power options to all Caps.
But didn’t made a diffenence.

@sodepop this doesn’t make sence to me. With your suggestion, my media box will turn on in an activity that it should be off. But I may got this wrong and didn’t understand the explanation.
Otherwise, I have added them to the Activity group and they are on the main screen.

At this moment I think the main issue here, is that, when switching an activity, the previous activity stay’s on.
So I doesn’t matter what I have configured in the OFF sequence, It doens’t get triggered anyway.

I don’t know what could be wrong at this point.

Did you try a restart of the R2 after everything with activity groups is configured? As I remember I had similar issues and after a restart things magically just did what they should.
I always try a restart when something doesn‘t do what it should.

I meant that each activity should do it’s own thing, without any dependency of anything else. Again, hard to explain. However, when you say activity group on the main screen…did you create a group in the user interface area and place/group the activities?

How do you restart the remote and the dock?

Hold down the power button on the remote to restart. Unplug the dock I guess to reboot that.

There’s no need to ask the same question in multiple posts.

Thank you! This was the solution!
After the reboot the is switching to off when selecting an other activity. Guess this is a bug.

And with the setting advised by @Tobbes to set the off commands to “In off sequence” the correct device is turned off.

For me the issue is resolved with this.


1 Like

The POWER_ON / POWER_OFF naming convention is just necessary for IR based remotes. For your used UC Denon integration it is not necessary. The integration knows by itself about their power state.

1 Like