Apple TV Integration Woes

When I attempt to install this integration, it seems to find three versions of the app, as shown below:

I have only one unit, and can’t find any old apps lying around my hard drive. Ideas?

Anyway, I charge ahead and try to install all three, failing each time. R2 asks for the “Pin”, which, according to Apple, does not exist. We assume they are looking for the Passcode, which I enter. Then after a few seconds of whirring, I get a Timeout error but with an encouraging Try Again message. Same every time. I’ve also tried leaving the PIN/Passcode entry unchanged from the defaulted “0”, and have also tried an empty field. No matter.

I could use some more help it seems. Thx in advance.

I don’t know if this is what you’re seeing, but Homepods also run TVOS and may be showing up here along with your AppleTV.

1 Like

isn`t the code shown on TV, when you try to connect ?


Two gold stars for @rccoleman who correctly figured that two of the three choices shown above were IN FACT homepods. Upon disconnecting those, I now am being shown only one choice, the true Apple TV, to integrate. So that’s an improvement.

But there’s a problem with the “Pin”:

This comment gave me pause and made me wonder whether I was talking about the same kit as R2 and the rest of you. I have been trying to integrate the 4 square inch Apple TV streamer, in my case model A1625 (32 GB) running 17.1 tvOS. No, @Helmi, no code shows when this thing boots up; just a home screen full of buttons for different streaming sources etc. If I am off base on the topic, please accept my apology and never mind.

But if I’m not, this thing I’m calling an Apple TV has a 4-digit PASSCODE (not called a Pin by Apple unless, again, we’re talking about two different kits), which is set and referenced under its Settings/Restrictions/Restrictions. I can’t find a “pin” anywhere but would be grateful for any directions.

Anyway, the Passcode I enter where R2 is asking for a Pin is taken, but the process ultimately times out. So, I need counseling on where a true Pin might be found. For the Pin, I have tried: 1) the 4-digit Passcode; 2) leaving the field as initialized with “0”; and 3) blanking it. None work.

Sorry to be long-winded. Just seeking clarity – and additional help.

I just connected my new Apple TV today. When you run the integration and select the Apple TV, the 4 digit appears on the TV screen from the Apple TV (you need to be viewing the Apple TV). Once you key in the PIN, a second 4 digit code will be requested, again, it is displayed on the screen connected to the Apple TV. Then you are in…

You need to set Access under ‘Settings ➜ AirPlay and HomeKit’ to “Same Network” on the Apple TV.
After that, the Apple TV will show the codes when you add it to the remote

1 Like

Many thanks for your helpful comments, @AdeRussell and @BalooDK . But we must be talking about different generation kits; I’ve never seen one Pin in the normal running of Apple TV, let alone two. :slight_smile:

@BalooDK, my Allow Access entry is set to “Same Network”; “Anyone on the Same Network” is checked,;“Require Password” (not Pin) is set to “On”; and a six-digit Password is entered.

In the normal operation of my Apple TV, I never see nor am asked for a Pin/Passcode/Password. It seems I entered those when I first purchased it, and never again.

I’m using the 2022 Apple TV 4K (the latest one). But I was previously using the earlier generation 4k one. Both did the pop up screens. I also had never seen this in normal use - even when pairing other Bluetooth remotes. I think I once saw it when setting up airplay, but it is certainly not a standard thing.

Well thanks everyone for their help. I think I am and will continue to be stuck on entering the infamous Apple pin into the integration routine. So far I’ve tried: what is called my passcode; 0;1111;1234; and a blank. If there are other hidey holes where this pin may reside, please pass it along.

And truly, thanks for your time and efforts.

It worked for me when enabling ‘same network’ and disabling password under the AirPlay setting. AppleTV popped up pin when connecting remote

HUZZAH HUZZAH. Congrats to @BalooDK for cracking the latest code. The solution was to DISABLE the password under the AirPlay setting as per Baloo’s last post. It might have been weeks before I stumbled across that simple fix.

Anyway, the two Pins showed just as everyone said they would and my AppleTV is now integrated. I have no idea what to do next to make AppleTV operational on the R2, but I’ll count this as a victory.

Sadly, however, I am finding out I’m not the “Kickstarter type”. It seems I am quite good reading a user’s manual or quick start guide. But without either, I’m pretty hapless.

I think I’ll wait awhile before I post my other dumb questions. Maybe log in under an assumed name. :slight_smile: Thanks again.


I’m happy I could help. You are not alone having difficulties setting this thing up, and the whole point of a community like this, is to help each other. Don’t give up yet


Another happy user that benefited from this discussion topic, thank you! There is a user guide that does not include this information on the apple Integration. It would be great if you could update the Apple Integration section.

I need help now adding adding volume control for my Panasonic TV when using Apple TV, volume control Apple TV when using headphones, and volume control when using Apple TV with Rotel AVR when using 5.1 audio.

I’ve posted my share of dumb questions, before the light bulb lit. There’s no shame in it.

1 Like