Strange problem with dock, cable and wall wart

Received my remote couple of days ago. Nice packing btw.
When I connected the wall wart with the dock nothing happened. I‘ve tried a different wall wart with no other outcome. After changing the cable (with one from my playstation) the green network led was on for a short time. That worked.
So the cable seems to be the problem. But here is the strange thing - I can charge my playstation controller with the original remote cable. That works.
I‘ve have no idea, what the problem is. I tried the original cable today again with no luck, the problem persists.
Can somebody offer an explanation?

When you put the usb c connector of the original and the new cable next to each other; is one of the connectors longer (the metal shield)?

I also have a similar problem with one of the included cables (I ordered two docks). The connection on this cable is shaky. When you get to it, the dock is not powered. The cable works elsewhere. I replaced the original cable with another one and it works fine.

I suspect that the USB socket in the dock is located too far into the housing and therefore doesn’t work well with the USB cables.

Cut of 0.5-1 mm of the plastic and it will work. Or get a cable with a connector with a slightly longer connector

1 Like

Thanks for asking about the USB Connector. You a right, the plug ist a little bit shorter on the original cable than on the one from the playstation cable. Looks like that this is causing the problem.

1 Like