IR learned codes to hard buttons - Help

Hi ALL,

I finally found an IR code database for the Frontier DVR and was able to copy and paste the codes into learned buttons. When the learned buttons is shown as a soft button in the display (although I don’t know how it got there!) it works. But when I assign it to a hard button nothing happens when I press the hard button. I know the hard buttons work as my LG TV uses one of the generic codes and the hard buttons work.

I’ve tried different learned codes on to different hard buttons and none of them work. Any help would be greatly appreciated.

Thanks,
Gerry

Hey Gerry, glad you were able to find an IR code set that works. I am wondering if something is incorrectly configured within the activity.

See the two images below on my end - the activity has multiple relevant devices added, and you can see how I have different “hard” buttons showing the different devices:


While I don’t have the temperamental device and still need to work out how to “throw the hood open” on the dock so I can get some more detailed logs, I do see two interesting threads that might give some insight into why you had trouble learning the codes, and it might also explain why you’re having trouble getting the commands to repeat.

Also - I don’t work for unfolded circle, I’m just trying to get my hands dirty so I can get my remote working the way I want. Regardless, it would be extremely helpful if you’re able to share more detail to recreate issues: steps, screenshots, screen recordings, etc.

I’m experiencing the same issue. Can map an IR code to a soft button, but not a hard one.

1 Like

HI. After making some progress it looks like I’m back to zero as I can’t get the firmware to update! And it looks like someone else cannot get a learned IR code to work with a hard button.

I’ll still play around with it but my frustration level is growing again!

Gerry

Just to add another datapoint; I too am experiencing this issue. I have two ir devices with learned commands. One (Philips tv) I can control using both hard and soft buttons, the other (Logitech squeezebox touch) only works via soft buttons.

Latest firmware.

1 Like

Playing around with things some more, it seems the problem is sporadic.

Some background info: The transport commands for Squeezebox Touch are available both via the home assistant integration and an IR remote device, but to navigate its menus I need IR. I have successfully learnt all the IR commands from an old Harmony remote (all the commands work fine when testing them from the IR dataset window).

I have defined an activity that use both the home assistant integration and the IR remote to be able to use its extra commands.

When I first tried this I was not able to use any IR commands added to the hard buttons (I think I also tried HA commands for the transport buttons, and those were working, but I’m not 100% sure about that).

I just now did another attempt at setting this up, and this time around, the IR commands for up, down, left, right, ok, next and prev works fine using hard buttons. Yay! The play/pause button, however, now doesn’t work with neither IR nor HA. Tapping the cover image shown on the screen (provided by the HA integration), will play/pause fine.

If I use the IR remote device instead of the activity, all the assigned buttons work.

1 Like

I have 9 activities currently and 6 IR “remotes”. Also have a few custom IR codes/commands learned from my manufacturer (denon) remote. I am able to assign and use these commands on physical buttons in both my activities and also when in “device” mode too. These commands are assigned via the colored buttons and work just fine. FYI…I just learned the buttons in the Remotes section, gave it a name, etc. After that, I can use it anywhere and assign to a physical button via activity “edit user interface” and/or from the “button mapping” section in the remote/device itself. The custom buttons are assigned to the device itself, so as long as it’s an “included entities” in your activity, should work fine.